Присобачиваемся к правительственной СПД

Наше прекрасное правительство решило сделать СПД через свою оптическую сеть. Эта статья о том какие тонкости там присутствуют и как реализовать проход голоса и данных в своей сети, через устройства CISCO. Рассчитана на админов гос. учреждений, кому выпало такое счастье. А также рассчитана на более менее начинающих цисководов
Собственно что мы имеем:

1. Группу коммутаторов CISCO 2950, один коммутатор 2690
2. Маршрутизатор CISCO 2600 (для прохода данных)

Как выглядит схема подключения?

Вход представлен коммутатором CISCO Metro Ethernet XXX, через который подходит один кабель
Также имеется 2 VLAN-а:
(172.27.27.0) 27 - Data - собственно проходят данные
(172.27.127.0) 127 - Voice - голос
172.27.27.254 - адрес шлюза данных

Учтите, что выделенные VLAN-ы будут иметь другую нумерацию, но будут находится в подсети 172.27.0.0!

Делаем:

На вход выделяем один коммутатор (желательно). В моем случае это был 2960. Дальше него стоит группа обособленных коммутаторов 2950.

0. Приходящий кабель - соединяем с коммутатором, на 1 порт (он будет у нас транком, с доступом в 27 и 127 VLAN соответственно)
1. Кабель уходящий на интерфейс fa0/0 маршрутизатора 2600 - будет у нас транком по которому мы будем делать проход данных по 27 VLAN-у. Для этого втыкаем его в fa0/22 на коммутаторе, который позже настроим.
2. Кабель из интерфейса маршрутизатора 2600 (fa0/1), втыкаем в сетевой коммутатор (участник сети).
3. Один кабель из коммутатора (предпоследний fa0/23) соединяем с одним сетевым коммутатором 2950

Приступаем:

Думаю ненадо говорить про первоначальную настройку коммутатора (представим что вы уже создали vlan 1, присвоили пароли)

Делаем проход голоса, и проход данных в маршрутизатор 2600:

На коммутаторе 2960:

0. Создаем VLAN 127
vlan 127
ip address 172.27.127.253 255.255.255.0
no ip route-cache

1. Можете назначить акцесс листы на доступ к коммутатору
2. На интерфейсе fa0/22 (который уходит в 2600) делаем доступ на 27 VLAN:
description data-flow
switchport access vlan 27

3. Настраиваем интерфейс на входе:
interface FastEthernet0/1
switchport trunk allowed vlan 27,127
switchport mode trunk

4. Теперь оставшийся какой нибудь порт пробуем сделать транком для прохода 1 и 27 vlan:
switchport trunk allowed vlan 1,127
switchport mode trunk
switchport voice vlan 127
spanning-tree portfast

и пробуем воткнуть туда IP телефон. IP телефон должен быть поставлен из правительства. Он должен суметь скачать свою прошивку, и зарегистрироваться на SIP сервере.

Далее на всех портах под которыми будут телефоны надо сделать аналогичное:
switchport trunk allowed vlan 1,127
switchport mode trunk
switchport voice vlan 127
spanning-tree portfast


А на транковых интерфейсах 2950:
switchport trunk allowed vlan 1,127
switchport mode trunk


Делаем проход данных

1. Коннектимся к CISCO2600
2. Размечиваем интерфейсы. Как я говорил приходящий из 22 порта 2690 кабель должен быть соединен с fa0/0, а fa0/1 должен идти в сеть.
3. Делаем такие настройки:

fa0/0 - outside
fa0/1 - inside

На входящем интерфейсе:
interface FastEthernet0/0
ip address 172.27.27.1 255.255.255.0 # из 27 VLAN-a
ip nat outside
duplex auto
speed auto
no mop enabled


На интерфейсе который уходит в сеть, присваиваем IP из своей подсети

interface FastEthernet0/1
ip address 10.186.187.254 255.255.0.0
ip nat inside
speed auto
half-duplex
no mop enabled


делаем маршрут
ip route 0.0.0.0 0.0.0.0 172.27.27.254


делаем типичные правила для NAT
access-list 1 permit 10.186.0.0 0.0.255.255

ip nat inside source list 1 interface FastEthernet0/0 overload


Теперь пробуем через 10.186.187.254 открыть какой нибудь узел.

Если че непонятно - задавайте в комментах.
  • 27 ноября 2011, 23:07
  • leonard
  • просмотров: ~2553
  • рейтинг: ?

Комментарии (5)

Вы - anonymous, войти ?

можно использовать bbcode-теги
[b]жирный текст[/b]
[i]курсив[/i]
[u]underline[/u]
[s]зачеркнутый текст[/s]
[size=20px]размер шрифта[/size]
всякие изменения текста
[left][/left]
[right][/right]
[center][/center]
позиционирование элементов: картинки, текст и т.д
[url][/url]
[email][/email]
внутри тега [url] помещайте ссылки, а внутри [email] адрес электронной почты;
так же [url] можно использовать в виде:
[url=http://example.com]пример[/url],
[url=http://test.ru][img]http://flickr.com/givemeimg.png[/img][/url]
[code][/code]
[quote][/quote]
внутри тега [code] можно помещать программный код (подстветка попытается включиться автоматически); для выделения цитат используйте [quote]
также можно напрямую указать язык [code=cpp]int i;[/code]
[list][/list]
создаем списки, каждый элемент пишется после [*].

Можно указывать маркер - [list=marker].
возможные маркеры 1(decimal), i(lower-roman), I(upper-roman), a(lower-alpha), A(upper-alpha). Примеры:

[list][*]1 элемент[*]2 элемент[*]3 элемент[/list]
[list=1][*]1 элемент[*]2 элемент[*]3 элемент[/list]
[list=A][*]1 элемент[*]2 элемент[*]3 элемент[/list]
[table][/table]
оформляем таблицу, используя внутренние теги [tr] и [td].
[tr] - строка, [td] - поле в строке,
[table=100%] - можно задавать ширину в процентах, по-умолчанию ширина 100%
[td=2] - можно задавать сколько столбцов входит в это поле. Пример:

[table=50%][tr][td]столбец 1[/td][td]столбец 2[/td][/tr][tr][td]значение 1[/td][td]значение 2[/td][/tr][tr][td=2]сразу 2 столбца[/td][/tr][/table]
[img][/img]
тег для вставки фото или картинок, мы любим картинки. Примеры использования:

[img]http://ya.ru/logo.png[/img],
[img=100x100px]http://ya.ru/logo.png[/img]
[img=fullimg.url]thumbimg.url[/img],
Пожалуйста загружайте картинки на наш сайт, либо вставляйте с бекбоновских ресурсов.
[video][/video]
Проигрывает видео, внутрь вставляем ссылки на видео, поддерживается Play.Ykt.Ru(нужно вставить ссылку на страницу с видео) и tv.ykt.ru(нужно вставить ссылку на адрес файла)